最新Magento 2.3.7兼容扩展的PHP 7.4兼容性要求即将发布

作者:admin 点击数: 0 收藏到会员中心
最后编辑时间: 2021-02-25 09:50:26

Please review the following announcement. To see the entire list, log into Magento Marketplace Developer Portal and click on the Resources option on the top menu bar.

Marketplace update: PHP 7.4 compatibility requirement for Magento 2.3 compatible extensions coming soon


Dear Magento Marketplace extension vendors,

We would like to remind you that PHP 7.4 support will be added in the Magento 2.3.7 patch release, which is planned for May 11, 2021. In addition, PHPUnit 6.5 will be deprecated and support of PHPUnit 9 will be added.

Since EQP requires support of the latest M2 and PHP versions for a given release line, we will start running tests using PHP7.4+PHPUnit9 for both 2.3 and 2.4 release lines.

When developing new extension versions for Magento 2.3.7+ compatibility, please ensure your extensions support PHP 7.4 and PHPUnit 9+. Specifically, look out for potential issues with tests – for more details, please refer to this DevBlog article.

Keep in mind that our Partners can get early access to beta code packages. They become available at least 1 month in advance, e.g. packages for 2.3.7 will be available April 6th the latest. For details on our Partner Early Access program, check out https://github.com/magento/magento2/wiki/Magento-Beta-Program.

尊敬的Magento市场扩展供应商:

我们想提醒你的是,在Magento 2.3.7的补丁中会增加对PHP 7.4的支持,计划于2021年5月11日发布。另外,PHPUnit 6.5将会被弃用,并且会增加对PHPUnit 9的支持。
由于EQP需要支持给定版本线的最新M2和PHP版本,我们将开始使用PHP7.4+PHPUnit9对2.3和2.4版本线运行测试。
当为Magento 2.3.7+兼容性开发新的扩展版本时,请确保您的扩展支持PHP 7.4和PHPUnit 9+。具体来说,要注意测试的潜在问题——要了解更多细节,请参考这篇开发博客文章。
请记住,我们的合作伙伴可以尽早访问beta代码包。至少提前1个月即可使用,例如2.3.7版本最晚4月6日即可使用。有关我们的合作伙伴早期访问计划的详细信息,请访问https://github.com/magento/magento2/wiki/Magento-Beta-Program。

请登录继续浏此文章所有内容!
会员中心

已经有帐号啦 !赶紧同小伙伴们愉快地玩耍吧

立即登录

还没有账号? 马上注册一个新帐户

注册账号
内容说明:
如您需要转载本文请保留以下信息是对作者发文的支持与尊重:

最新Magento 2.3.7兼容扩展的PHP 7.4兼容性要求即将发布 来源于 https://www.magentola.com/news-read-208.html
上一篇:Magento商务企业版2.4.2更新说明
下一篇:php判断手机端方法
相关内容
产品推荐
网站客服