Magento2.4-环境及配置要求

作者:admin 点击数: 0 收藏到会员中心
最后编辑时间: 2020-06-27 17:47:59

要求组件条件:

在安装Magento Commerce或Magento Open Source 2.4.0之前,您必须安装Elasticsearch组件用于解决搜索的大难题,此组件可以用于大数量的准确检索。

操作系统要求:

可以使用Linux发行版,例如RedHat Enterprise Linux(RHEL),CentOS,Ubuntu,Debian等。Magento默认支持不友好的操作系统:
Windows操作系统
苹果系统

内存要求:

magento后台自带的市场及其它一些扩展在线安装时内存可能会使用达2GB,如果您PHP内存可用量少于2GB,记得要建立一个SWAP缓存机制,否则,会有安装失败或是升级失败的提示。

Composer要求版本:

建议安装最新的稳定版


网络服务器:

Apache

另外,您必须启用Apache mod_rewrite和mod_version模块。该mod_rewrite模块使服务器能够执行URL重写。该mod_version模块提供了针对不同httpd版本的灵活版本检查。有关更多信息,请参见我们的Apache文档。

Nginx

1.x版本

数据库
MySQL 5.7.9和8.0

Magento还与MySQL NDB Cluster 7.4。*,MariaDB 10.2、10.4(推荐)Percona 5.7和其他与二进制兼容的MySQL技术兼容。

Magento仅使用与MariaDB兼容的MySQL功能。MariaDB可能与所有MySQL功能都不兼容,因此,请确保在Magento模块兼容性是否有问题再使用MAGENTO及第三方的模块。

Php版本

7.3

7.4

虽然Magento支持PHP 7.3,用PHP7.4会有一些错误,某个错误不会让某些消息正常呈现,但是大体不影响,因此我们还是建议使用PHP 7.4。


所需要的PHP组件

    ext-bcmath

    ext-ctype

    ext-curl

    ext-dom

    ext-gd

    ext-hash

    ext-iconv

    ext-intl

    ext-mbstring

    ext-openssl

    ext-pdo_mysql

    ext-simplexml

    ext-soap

    ext-xsl

    ext-zip

    lib-libxml

PHP opcache组件是一款非常不错的缓存组件,建议启用它

关于PHP设置的问题,请一定要避免出现memory_limit的错误,运行至少要756M内存,编译代码及部署静态文件就够用了,如果是安装组件或是更新组件则需要至少2G,如果是测试状态的话可能最少要3G内存

弹性搜索

从Magento 2.4.0开始,MySQL不再用于搜索。您必须使用Elasticsearch。Magento支持Elasticsearch7.6.x及以上版本。

SSL

    HTTPS需要有效的安全证书。

    不支持自签名SSL证书。

    传输层安全性(TLS)要求-贝宝(PayPal)和repo.magento.com两者均要求TLS 1.2或更高版本:

邮件服务器

邮件传输代理(MTA)或SMTP服务器


Magento可以使用的技术

    用于页面缓存和会话存储的Redis版本3.2、4.0、5.0(与2.4+兼容)。强烈建议使用5.0版。

    Varnish版本6.x(已通过6.3.1测试)

    RabbitMQ 3.8.x(与2.0及更高版本兼容)

    RabbitMQ可用于将消息发布到队列中,并定义异步接收消息的使用者。

仅Magento Commerce

    三个主数据库

    这些主数据库为Magento应用程序的不同功能区域(如结帐,订单和所有剩余的Magento2应用程序表)提供了可伸缩性扩展的优势(开源免费版本无此功能)。

请登录继续浏此文章所有内容!
会员中心

已经有帐号啦 !赶紧同小伙伴们愉快地玩耍吧

立即登录

还没有账号? 马上注册一个新帐户

注册账号
内容说明:
如您需要转载本文请保留以下信息是对作者发文的支持与尊重:

Magento2.4-环境及配置要求 来源于 https://www.magentola.com/news-read-145.html
上一篇:Magento2.x 使用Redis加速cache及Session操作实用指南教程
下一篇:Magento2.4-支持的浏览器
相关内容
产品推荐
网站客服